Transactions and Add Sources pages are failing to load

Incident Report for TaxBit

Resolved

This incident has been resolved.
Posted Jan 24, 2023 - 21:04 UTC

Investigating

We have identified an issue that causes the Transactions page and Add Sources to fail to load.
A fix is being investigated right now.
Posted Jan 24, 2023 - 19:57 UTC