Transaction data now visible in the Transactions page on the Taxbit dashboard.
Newly ingested data will continue to be slightly delayed as we monitor the new replication process. However, live transaction data can be viewed on the transactions tab on the account details page.
Transaction ingestion (via API and file upload) continue to be unaffected.
Posted Dec 23, 2025 - 19:56 UTC
Update
Status: Data backfill in progress. Full mitigation anticipated 2025-12-23 12:00 PT
Current impact: Transaction data ingested after 2025-12-10 may not appear in the Transactions Page within the Taxbit dashboard. Transactions page export and other Dashboard reports may also not include recently ingested data. Transaction ingestion (via API or File) IS NOT impacted. Transaction details pages are also not impacted. No production data loss or corruption was experienced during the event.
Next update: 2025-12-23 12:00 PT
Posted Dec 22, 2025 - 23:14 UTC
Update
Status: Root cause of data replication lag has been identified and addressed. Team is actively working towards resolution of data visibility.
Current impact: Transaction data ingestion after 2025-12-10 may not appear in the Transactions Page within the Taxbit dashboard. Transactions page export and other Dashboard reports may also not include recently ingested data. Transaction ingestion (via API or File) IS NOT impacted. Transaction details pages are also not impacted.
Next update: 2025-12-22 15:00 PT
Posted Dec 22, 2025 - 18:56 UTC
Update
Status: Team actively working on addressing source of root cause.
Current impact: Transaction data ingestion after 2025-12-10 may not appear in the Transactions Page within the Taxbit dashboard. Transactions page export and other Dashboard reports may also not include recently ingested data. Transaction ingestion (via API or File) IS NOT impacted. Transaction details pages are also not impacted.
Next update: 2025-12-22 11:00 PT
Posted Dec 22, 2025 - 06:00 UTC
Identified
We have identified the source of the delays. The team is working on steps to resolve the issue.
Posted Dec 19, 2025 - 21:01 UTC
Investigating
We are investigating data sync delays to our data warehouse. Reports and transaction data may be temporarily delayed, but there is no impact on data ingestion.