Help Center Outage
Incident Report for TaxBit
Resolved
This incident has been resolved.
Posted Oct 25, 2022 - 19:23 UTC
Monitoring
Zendesk has reported an outage with Guide, our Knowledge Base vendor. We are monitoring their incident, and will update this status when it is resolved.
TaxBit's Knowledge Base may be unavailable.
Posted Oct 25, 2022 - 17:39 UTC
This incident affected: Consumer Web App.