Dashboard pages not loading
Incident Report for TaxBit
Resolved
This incident has been resolved.
Posted Apr 27, 2024 - 20:39 UTC
Update
We are continuing to investigate this issue.
Posted Apr 27, 2024 - 16:45 UTC
Investigating
We are investigating an issue which is causing parts of certain pages in the dashboard to not load, including the Accounts page and the Information Reporting Summary page.
Posted Apr 27, 2024 - 16:41 UTC
This incident affected: Tax Dashboard.