TaxBit Consumer Login Unavailable
Incident Report for TaxBit
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 00:30 UTC
Identified
We have identified an issue affecting the ability to login and use TaxBit's app. This issue is being investigated and a fix will be implemented shortly.
Posted Mar 02, 2023 - 23:26 UTC
This incident affected: Consumer Web App.