Some users are currently experiencing issues with not seeing new tax calculations.

Incident Report for TaxBit

Resolved

This incident has been resolved.
Posted May 18, 2022 - 02:41 UTC

Monitoring

we have identified the issue and are currently working on a fix.
Posted May 17, 2022 - 01:02 UTC