Dashboard Authentication Errors

Incident Report for TaxBit

Resolved

This incident has been resolved.
Posted Nov 16, 2025 - 20:27 UTC

Investigating

The identity platform we use for user authentication (Auth0) is experiencing elevated error rates, which are preventing users from logging in to the TaxBit dashboard.
Posted Nov 16, 2025 - 20:10 UTC
This incident affected: Tax Dashboard.